Инновационный подход к разработке электроникиИнновационный подход к разработке электроники

 

История версий SimOne

Изменения в обновлениях версии SimOne 2.7

Изменения в версии SimOne 2.7

  Система обновления версии SimOne работает при наличии доступа компьютера пользователя к сети интернет  и позволяет удобно и быстро обновить используемую версию программы на последнюю, выпущенную разработчиками. При обновлении система производит резервное копирование текущей версии и впоследствии разработчик может вернуться к ней.

Вызов окна обновлений  



осуществляется из окна справки SimOne: меню Справка→О программе...



Восстановление предыдущей версии программы осуществляется нажатием на соответствующую кнопку окна справки SimOne.

Математические выражения

Добавлены функции, для работы с преобразованием Фурье:



Эти функции могут быть использованы в выражениях для вывода на график, но не могут в выражениях, описывающих поведение компонента.

Пример использования функций преобразования Фурье - файл-схема fft_based_func.ssch содержится в папке FFT с примерами SimOne. Доступен через меню Файл→Открыть Примеры...  

Исправления

- Исправлены ошибки работы с подсхемами и др.

Изменения в обновлениях версии SimOne 2.6 Beta

Изменения в версии SimOne 2.6 Beta

Что нового в SimOneОбратная связь с разработчиками

Отправить запрос, сообщение или пожелание разработчикам теперь можно используя форму обратной связи в самой программе: меню Справка → Обратная связь.





В окне отправки запроса разработчикам можно указать адрес электронной почты для обратной связи, имя пользователя,  тему запроса и текстовое сообщение.Также необходимо выбрать тип запроса:
- Вопрос.
- Предложение или пожелание.
- Ошибка в работе программы.
- Замечание об интерфейсе.

К отправляемому сообщению можно приложить следующие документы:
- Схему\нетлист.
- Снимок экрана.
- Информацию о системе.
- Файл.

Просмотр истории отправленных сообщений доступен по нажатию кнопки История запросов.



Синтез фильтров

SimOne теперь позволяет проводить параметрический синтез электронных схем активных и пассивных фильтров. Для этого он содержит свой собственный конструктор фильтров, использующий  как классические схемы реализации, так и оригинальные.

Разработка фильтра производится в интерактивном режиме: любые внесенные пользователем изменения требований к характеристике фильтра вызывают автоматический пересчет параметров схемы и перестроение частотных характеристик в окне предпросмотра.



Touchstone-модели и многополюсные компоненты

SimOne теперь поддерживает многополюсные компоненты, задаваемые с помощью S-, Z-, Y-параметров.

Параметры могут задаваться как в виде выражений, так и с помощью текстовых файлов Touchstone-формата.



Многополюсные компоненты  могут быть установлены на схему:

- c помощью соответсвующих примитивов: кнопки на панели

- с помощью подключенных библиотек Touchstone-моделей:



Добавлена новая настройка для Лапласовых источников и многополюсгиков:maxF\Fmax – максимальная частота, определяет шаг квантования обратного преобразования Фурье.

Графический  модуль

Добавлена возможность отображать графики частотного анализа схемы на диаграмме Вольперта-Смита





Экспорт графиков

Добавлена возможность экспортировать графики частотного анализа в форматах Touchstone и Freq

Окно экспорта данных в Touchstone-файл:



содержит следующие настройки:




Окно экспорта данных в Freq-файл:



Рис. 20.16.5 Окно экспорта графика в Freq-файл

содержит следующие настройки:



Математические выражения

Добавлены функции, реализующие следующие измерения:





Эти функции могут быть использованы в выражениях для вывода на график, но не могут в выражениях, описывающих поведение компонента.

Исправления 

- Исправлены ошибки интерпретации числовых сокращений и др.  

Изменения в обновлениях версии SimOne 2.5

Изменения в версии SimOne 2.5

Лапласовы источники

- Функциональные источники тока и напряжения, задаваемые с помощью  передаточной функции Лапласа, теперь выведены в отдельную группу в схемотехническом редакторе.  Каждый источник имеет свое УГО.



- Добавлены новые алгоритмы и настройки вычисления интеграла свертки  для Лапласовых источников.





- Передаточная функция теперь модет быть задана в табличном виде. Это реализуется с помощью специального набора функций с префиксом freq_.

Расчет периодических режимов

Изменен интерфейс анализа периодических режимов:

- интервал построения графиков выходных величин теперь задается просто числом периодов искомого периодического режима. Значение по умолчание -10.

- Максимальный шаг интегрирования определяется количеством точек на период, задаваемых пользователем. Значение по умолчание -20.



 Обработка кусочно-линейных сигналов

Доступны новые настройки моделирования для кусочно-линейных синалов:



Графический  модуль

- Добавлена возможность логарифмировать оси графиков.



- Окно масштабирования графика:





- Добавлена возможность импорта графиков из файлов-данных результатов моделирования в SimOne.

 Отображение гистограмм:

 Математические выражения

Добавлены следующие функции интегральных преобразований:




Исправления 

- Исправлена вычисление функции Лапласа в частотном анализе.

- И др.

Изменения в обновлениях версии SimOne 2.4

Изменения в версии SimOne 2.4

Поддержка внешних библиотек

Все подключенные внешние библиотеки  – SPICE-библиотеки  и файлы-схемы SimOne, содержащие подсхемы теперь отображаются в соответствующих разделах пункта “Добавить” главного меню программы. Любой компонент из этих библиотек доступен для размещения на схеме.





Обработка событий

SimOne позволяет отслеживать различные события, которые происходят в процессе моделирования схемы.
В качестве типа событий могут быть выбраны следующие:
- Локальный максимум выражения.
- Локальный минимум выражения.
- Пересечение выражением указанного значения.
- Величина наклона кривой.
- Точка перегиба кривой.
- Любое условное выражение.
Обработка событий включает в себя следующие действия:
- Остановка моделирования.
- Пауза.
- Запись в журнал.

Окно обработки событий:



Статистический анализ  в многовариантном расчете схемы

К многовариантным видам анализа схемы добавлен Статистический анализ\Анализ наихудшего случая. Он позволяет производить анализ схемы с учётом разброса параметров её компонентов. Для любого параметра схемы (параметра отдельного элемента, параметра модели компонентов, параметра сигнала источников или глобального параметра) могут быть заданы диапазон разброса и закон вероятностного распределения.
Статистический анализ многократно повторяет анализ схемы при изменении её параметров по указанному вероятностному закону. Результатом такого расчёта являются полученные семейства графиков схемы, а также гистограммы распределения исследуемых характеристик.

SPICE-формат

.МС  <количество запусков> <тип анализа схемы> <выражение1> <выражение2>...<имя измерения1> <имя измерения2> ...

Примеры:

.MC 100 tran V(out) I(Rн) Vmax Imax
.MC 10  ac db(V(Rн)) Band1
.MC 100 dc I(Rн) Imax

Вкладка Анализ Монте-Карло окна задания параметров моделирования:



Окно отображения результатов моделирования:



Гистограммы

Гистограммы являются альтернативным способом представления результатов моделирования и показывают распределение численных значений графических кривых на интересующих интервалах.

Окно добавления гистограмм:



Отображение гистограмм:



WAV-файлы

Добавлена поддержка задания сигналов в аудио-формате (*.wav-файлы).
Экспорт графиков теперь также доступен в wav- формате при этом аудиопотоки  могут быть  выведены на динамики компьютера.

Математические выражения

- Добавлена поддержка функций генерации случайных величин;
- Добавлена поддержка интегральных преобразований.

Исправления

- Исправлена обработка сигналов PWL-типа.
- И др.

Изменения в обновлениях версии SimOne 2.3

Изменения в версии SimOne 2.3

Статистический анализ\Анализ наихудшего случая

Позволяет производить анализ схемы с учётом разброса параметров её компонентов. Для любого параметра схемы (параметра отдельного элемента, параметра модели компонентов, параметра сигнала источников или глобального параметра) могут быть заданы диапазон разброса и закон вероятностного распределения.

Статистический анализ многократно повторяет анализ схемы при изменении её параметров по указанному вероятностному закону. Результатом такого расчёта являются полученные семейства графиков схемы, а также гистограммы распределения исследуемых характеристик.

Окно задания параметров расчёта





Для запуска анализа наихудшего случая необходимо указать соответсвующий закон распределения варьируемого параметра схемы – Wcase или AWCase. В этом случае на каждом запуске расчета варьируемый параметр будет принимать только  свои граничные значения.

Анализ чувствительности измерений

Предназначен для определения тех компонентов схемы, параметры которых оказывают наибольшее влияние на ее выходные характеристики.

Анализ чувствительности обычно предшествует оптимизации схемы, позволяя существенно ограничить круг варьируемых параметров схемы и тем самым повысить  скорость и эффективность оптимизации.  Также анализ чувствительности позволяет выделить компоненты схемы, разброс параметров которых может оказать существенное влияние на ее характеристики. Таким образом, его результаты используются в анализе Монте-Карло\Наихудшего случая схемы. 

Окно задания параметров расчёта



Результаты расчета чувствительностей сгруппированы по заданным измерениям и представлены на соответствующих вкладках. 

В таблице представлены значения абсолютных и нормированных чувствительностей. Сравнительные гистограммы отображаются для указанного типа чувствительности. Изменить режим отображения гистограмм можно с помощью кнопки соответствующей кнопки переключения.



Анализ чувствительности схемы по постоянному току

 Анализ чувствительности схемы по постоянному току позволяет оценить влияние любого компонента схемы, параметра модели, температуры на интересующие статические характеристики схемы, позволяя выделить те параметры, влияние которых максимально.

SPICE-формат

.SENS <выражение1> <выражение2> …

<выражение> – выражение, для которого будет рассчитана чувствительность

Примеры:

.SENS v(out)

.SENS {v(out)*I(Rout)} Vbe(Q1)

Окно задания параметров расчёта



Результаты расчета чувствительностей сгруппированы по заданным выражениям и переменным и представлены на соответствующих вкладках.



Преобразование Фурье

Выражения для преобразования Фурье могут быть заданы теперь  следующим образом:

SPICE командой .FOUR;с помощью вкладки Фурье в окне задания на симуляцию;с помощью окна преобразования Фурье в постпроцессной обработке.

Команда .FOUR может быть задана в тексте, в случае, если схема задается  в виде  нетлиста, или помещена на схему с помощью SPICE-блока, если схема разрабатывается в схемотехническом редакторе.

SPICE\LTSPICE Синтаксис:

.FOUR <частота> [<число гармоник >] [<число периодов >]

+<выражение1> <выражение2>…

Примеры:

.four 1KHz V(out)

.four 10KHz  3 V3(out)

Вкладка преобразования Фурье доступна при следующих видах анализа схемы:
– Анализ переходных процессов
– Расчет периодических режимов
– Частотный анализ



Исправления

– Исправлена обработка модели операционного усилителя.
– И др.

Изменения в обновлениях версии SimOne 2.2.1

Изменения в версии SimOne 2.2.1

Что нового в SimOne 2.2.1

- Добавлена поддержка  частоты (‘f’, ‘hertz’) в математических выражениях в качестве переменной.

Пример:
E1 1 0 value={hertz*v(1)+f^2*i(v1)}

- Функции TABLE и PWL теперь позволяют задавать свои параметры из текстового файла:
pwl(Выражение,“Имя файла”), able(Выражение,“Имя файла”).

Пример:

pwl(v(1),“Curve1.txt”),  table(sin(v(1))*i(v1),“ Curve1.txt”).

Содержание файла Curve1.txt:
0 0
0.1 10
0.3 60
1.0 1e3

- Изменена модель операционного усилителя: коэффициент усиления теперь может задаваться произвольным выражением.

Исправления

- Исправлена ошибка обработки объектов  из базы компонентов в схемотехническом редакторе.

Изменения в обновлениях версии SimOne 2.2

Изменения в версии SimOne 2.2

Схемотехнический редактор
- добавлен текстовый компонент SPICE описания схемы.
Позволяет задавать в SPICE формате описание схемы или ее части,  команды на моделирование и отображение результатов, команды на построцессную обработку.




- изменен формат хранения файлов схем.
- улучшен интерфейс работы с текстовыми компонентами редактора

Измерения
- Добавлена поддержка команд измерения .measureв HSPICE/LTSPICE/NGSPICE форматах.
- Добавлена поддержка команды измерений в формате SimOne.

Пример:
определение периода сигнала:

HSPICE/LTSPICE:
.meas period trig v(out)=0.5 rise=6 targ v(out)=0.5 rise=7
SimOne:
.meas period1 period v(out) 0.5 11

Определение полосы пропускания:

HSPICE/LTSPICE:
.meas ac tmp max mag(V(out)) 
.meas ac Bandwidth trig mag(V(out))=tmp/sqrt(2) rise=1
+                                targ mag(V(out))=tmp/sqrt(2) fall=last

SimOne:
.meas ac Band1 Bandwidth mag(v(out))

.Транслятор SPICE нетлиста
- добавлена поддержка команды  запуска Анализа устойчивости схемы:
  – .stab  hod  [log/lin] [eigen] – автоматический расчет устойчивости;
hod – определять устойчивость с помощью Годографа Михайлова;
log/lin – способ отображения годографа;
eigen – расчет собственных частот схемы.
  –  .stab  lin/dec/oct   <step>  <start>  < stop>  – построение годографа в указанном интервале;
<step>   - шаг/ число точек на интервал для построения годографа;
<start>, < stop> - начальная и конечная частота.
- Добавлена поддержка команды  запуска Расчета периодических режимов :
 .pss [<period>] [<Nperiods>] [<Maxinter>] [<tolerance>]
<period> – период процесса, если не указан – определяется автоматически;
<Nperiod>  – число периодов стабилизации;
<Maxinter>  – макс. число итераций;
<tolerance> – погрешность определения периодического режима.
- И др.

 Моделирование
- Улучшена сходимость методов при расчете статических характеристик схемы.
- Скорректирован контроль  выполнения закона токов Кирхгофа.
- Улучшено управление Симуляциями.

Математические выражения
- Добавлена поддержка операторов целочисленного деления:   \, DIV;
и взятие остатка после целочисленного деления:  %, MOD

Исправления
- Исправлена обработка команды .IC и флага UIC во временном анализе схемы.
- И др.

Изменения в обновлениях версии SimOne 2.1

Изменения в версии SimOne 2.1

Компоненты
Добавленные  следующие модели компонентов: 
Зависимые источники, описываемые передаточной функцией Лапласа
SPICE-описание:
E1 2 0 1 0 Laplace = s/(2*s^2+s*2+1)      – источник напряжения
G2 4 0 1 0 Laplace = exp(-s)                     – источник тока
Интерфейс задания в схемотехническом редакторе:

Функциональные источники, описываемые передаточной функцией Лапласа
SPICE-описание:
E2 2 0  LAPLACE{ V(1)+v(1)*v(2) } = s/(2*s^2+3*s+1)          – источник напряжения
B2 2 0  V= {V(1)+v(1)*v(2) }  laplace ={ s/(2*s^2+3*s+1)}      – источник напряжения
G2 3 0  LAPLACE{V(1)+v(1)*v(2) } = exp(-s)                         – источник тока
B3 3 0  I= {V(1)+v(1)*v(2) }  laplace ={ exp(-s)}                      – источник тока
Интерфейс задания в схемотехническом редакторе:

Независимые источники сигналов, заданных  произвольным математическим выражением (сигнал – Expression)
SPICE-описание:
E2 2 0  Value = {stp(2)*sin(t)}                        – источник напряжения
B2 2 0  V = {stp(2)*sin(t)}                              – источник напряжения
G2 3 0  Value = {stp(2)*sin(t)}                        – источник тока
B3 3 0  I = {stp(2)*sin(t)}                                – источник тока
Интерфейс задания в схемотехническом редакторе:

Моделирование
— Существенно улучшена сходимость методов при расчете временного анализа схемы.
— Скорректирован контроль  выполнения закона токов Кирхгофа.
— Новые интерактивные процедуры процесса разработки: для каждой симуляции добавлена возможность автоматического пересчета и вывода результатов при редактировании схемы или SPICE-нетлиста.
— Добавлены новые блочные методы проведения матричных операций, позволяющие существенно ускорить процесс разложения больших матриц и тем самым существенно повысить скорость моделирования схем. Скорость моделирования больших схем в SimOne увеличена в десятки и сотни раз.

В настройке матричного компилятора ‘MatrixSolver’ по-умолчанию используется автоматичекий выбор алгоритма разложения матрицы  в зависимости от размерности моделируемой схемы.
Математические выражения
— Добавлена поддержка констант PI = 3.14159265358979323846,  E  =  2.71828182;
— комплексных чисел: 1+ I, 1+i, 1+J,1+j.
Функции
Impulse(X)
– импульс с единичной площадью амплитудой X;
STP(X), U(X), uramp(X)  – единичная ступенька и линейно  нарастающая функции , начинающиеся при T>X;
DDT(x), SDT(x),IDT(x), IDTMOD(x) – функции численного дифференцирования и интегрирования;
EXPL(x,max) – экспонента с линейно ограниченной функцией :
EXPL(x,max)=exp(x) при x<max иначе EXPL(x,max)=exp(max)*(x+1-max );
BUF(x), inv(x)  – функции дисретизации:
buf(x)= 1 при x>0.5 иначе buf(x)= 0,
inv(x)= 0 при x>0.5 иначе inv(x)= 1;
ceil(x), floor(x) – функции округления
Транслятор SPICE нетлиста
— существенно повышена скорость синтаксического разбора SPICE файла;
— добавлена поддержка директив .define, .include;
— добавлена поддержка нового синтаксиса описания подсхем: перечисление параметров подсхем в ее описании теперь необязательно;
— добавлена поддержка синтаксиса произвольных источников тока и напряжения как компонент B:  B1 1 0 V = {uramp(2)*sin(t)} и т.д.
— скорректирована обработка подключения SPICE- библиотек (.lib).
 Схемотехнический редактор
— поддержка глобальных параметров в схемотехническом редакторе: добавлено окно задания  SPICE-директив  .param, .define, .func – глобальных для текущей  разрабатываемой схемы;

— улучшен интерфейс работы с текстовыми компонентами редактора.
Исправления
— Исправлен вывод результатов расчета гармонического режима схемы.
— Исправлена обработка команды NODESET.
— И др.

Изменения в обновлениях версии SimOne 2.0.2. Beta

Изменения в версии SimOne 2.0.2 Beta

Доступно обновление версии  SimOne 2.0
Что нового в SimOne 2.0.2

Нововведения:

-добавлена поддержка точки  как разделителя при обращении к элементам подсхем, например X1.R1,X1:R1,  X2.X1.Q2, X2:X1:Q2;

 Исправления:
- расчет периодических режимов в схемах с отсутствием накопителей;
- сигналы подсхем;
- обработка переменной времени ( T,TIME ) в параметрах моделей компонентов;
- использование пробелов в выражениях;
- и др.

Изменения в обновлениях версии SimOne 2.0.1. Beta

Изменения в версии SimOne 2.0.1 Beta

 Доступно обновление версии  SimOne 2.0
 Что нового в SimOne 2.0.1 Beta

 Нововведения:

- добавлены функции численного интегрирования и дифференцирования sdt() и ddt() в описании параметров компонентов при временном анализе схемы;
- добавлена поддержка точки старта в функциях sd(),avg(),rms().

 Исправления:
- совместимость с WinXP;
- модели операционных усилителей в библиотеке готовых моделей;
- подключение компонента из текстового файла библиотеки;
- расчет параметров модели длинной линии TLine;
- расчет переходнго процесса схемы;
- и др.

Изменения в обновлениях версии SimOne 2.0

Изменения в версии 2.0 Beta

Что нового в SimOne 2.0
Параметрическая оптимизация схем

Параметрическая оптимизация SimOne позволяет производить автоматическую настройку схемы, подбирая такие значения параметров электронных компонентов, при которых характеристики схемы достигают желаемых величин.
В качестве параметров варьирования могут быть использованы модельные параметры компонентов, отдельные параметры самих компонентов, глобальные параметры схемы, параметры сигналов источников.
Оптимизируемая функция может быть задана двумя различными способами:
с помощью Измерений, проводимых по результатам моделирования. При этом функция может быть как целевой (максимизация/минимизация) так и ограничением/равенством;
в виде графической кривой — требуемой/желаемой характеристики, к которой должны стремиться выходные переменные схемы.Доступны различные методы оптимизации: метод Пауэлла, метод Нелдера — Мида, метод дифференциальной эволюции.
Результаты работы модуля оптимизации могут быть сохранены в текстовый файл — кнопка , а текущие параметры компонентов схемы могут быть заменены на оптимальные  с помощью кнопки .
Создание симуляции Оптимизации:
Меню Симуляция → Оптимизация...
Подстройка параметров компонентов схемы
Теперь SimOne позволяет производить ручную настройку схемы. Режим ручной настройки представляет собой интерактивный процесс, в котором разработчик, изменяя значения варьируемых параметров компонентов (двигая соответствующие ползунки), вызывает автоматический пересчет характеристик схемы. Таким образом, подбираются желаемые характеристики.

В качестве параметров варьирования могут быть использованы модельные параметры компонентов, отдельные параметры самих компонентов, глобальные параметры схемы, параметры сигналов источников. Способы варьирования параметров стандартные: линейно, декадами, октавами, списком.

Вызов Окна Подстройки параметров: Меню Симуляция → Подстройка параметров...
Вывод текущих значений параметров компонентов
У каждого компонента схемы теперь есть свой паспорт данных, доступный для просмотра. Он включает в себя все входные параметры модели компонента и некоторые выходные — расчетные, такие как ток, мощность, емкость, заряд и др.
Все параметры компонентов, потенциалы узлов схемы, а также любые математические выражения от них можно теперь просмотреть в Окне текущих значений. Меню Вид → Текущие значения.

Также текущее состояние схемы может быть выведено в файл: меню Симуляция → Вывод текущих значений. В файле приводится информация о состоянии всех компонентов схемы, значения переменных состояния.
Компоненты
Добавлена поддержка следующих нелинейных компонентов:
нелинейный резистор,нелинейный конденсатор,нелинейная катушка индуктивности. Сопротивление резистора, емкость/заряд конденсатора, индуктивность/потокосцепление катушки может теперь задаваться произвольным выражением, включающим в себя потенциалы узлов, падения напряжений, токи источников и индуктивностей, а также различные математические функции от них.
Экспорт графиков
Добавлена возможность экспортировать графики в текстовом формате.

Изменения в обновлениях версии SimOne 1.6

Изменения в версии 1.6

Режим расчета рабочей точки схемы
Расчет рабочей точки схемы теперь представляет собой интерактивный процесс, в котором пользователь модифицирует схему, а программа автоматически производит пересчет текущей рабочей точки, отображая интересующие его результаты на схему и таблицу.
Окно задания параметров расчета рабочей точки схемы:

Таблица результатов расчета:

Анализ гармонического режима схемы
Анализ гармонического режима схемы включает в себя расчет малосигнальных параметров моделей компонентов, значений токов, напряжений  схемы при воздействии гармонических источников на заданной пользователем частоте.Расчет  гармонического режима схемы представляет собой такой же интерактивный процесс, как и расчет рабочей точки схемы.Окно задания параметров расчета гармонического режима схемы:

Таблица результатов расчета:

Многовариантный анализ схемы
Добавлена возможность выбрать в качестве параметра изменения: параметр компонента, модельный параметр, глобальный параметр схемы;
добавлена возможность изменять переменные списком.

SPICE нетлист
Добавлена поддержка следующих SPICE-команд:
.IC, .NODESET – для расчета рабочей точки,
.OPTIONS, OP, .TRAN, .AC, .STEP, .TEMP – для моделирования
.PLOT, .PRINT, .PROBE – для отображения результатов;добавлена возможность экспорта схемы из графического редактора в текстовый файл SPICE формата. 

Изменения в обновлениях версии SimOne 1.5

Изменения в версии 1.5.2

Что нового в SimOne 1.5.2
– Добавлена  настройка для управления максимальным током полупроводниковых компонентов  – Imelt.
– Выделен интерфейс расчета рабочей точки схемы с поддержкой директив .IC, .NODESET.
– Добавлена поддержка в выражениях функции  sgn(x) ( signum(x) )

Исправления
– Исправлены ошибки при расчете  параметров моделей V-SWITCH, I-SWITCH, MOSFET Level=1..3.
– И др.

Изменения в версии 1.5.1

Что нового в SimOne 1.5.1 Beta

Добавлены следующие настройки для управления временным анализом схемы:
–  LTERELTOL, LTEABSTOL – максимальные  абсолютная и относительная погрешности на шаге интегрирования;
– TRINIT – коэффициент для вычисления начального шага   интегрирования:  hinit  = TRINIT*hmax;
– TRMIN – коэффициент для вычисления минимального шага   интегрирования :  hmin  = TRIMIN*hinit;

Исправления
–  Исправлены ошибки при расчете  переходных процессов  схемы.
–  Исправлены ошибки при нахождении  периодических режимов.
–  И др.

Изменения в обновлениях версии SimOne 1.4 Beta

Изменения в версии 1.4.1

Что нового в SimOne 1.4.1 Beta

- Улучшены алгоритмы расчета рабочей точки в статическом анализе схемы.
- Улучшен расчет нелинейных параметров моделей полупроводниковых компонентов схемы.
- Расширены возможности текстового редактора SPICE-файлов.
-Улучшено соединение компонентов проводниками в схемотехническом редакторе.
- Добавлена возможность глобального поиска компонентов по базе данных.

Исправления

- Исправлены ошибки текстового интерпретатора SPICE файлов.
- Исправлены ошибки в моделях Diode,, PNP и MOSFET.И др.

Изменения в версии 1.4.0

Обработка результатов моделирования

- Фурье-анализ.
Добавлена возможность вычисления и отображения спектра графиков временных расчетов на основе быстрого преобразования Фурье.

- Для многовариантного анализа Измерения теперь считаются и каждого из значений.

Курсоры
Добавлены новые возможности в управлении курсорами на графических кривых:
- Установка курсоров в заданное Измерение.

- Установка курсоров в заданные положения по оси Х и Y.

- Быстрая установка курсоров в минимумы, максимумы, пики и впадины кривых.

Моделирование.
- Улучшена сходимость методов при расчете рабочей точки схемы.
- Добавлена возможность управления точностью расчета рабочей точки с  помощью контроля погрешности выполнения ЗТК.
- Улучшен интерфейс задания параметров многовариантного анализа.
- Добавлена  возможность создания измерений на этапе создания задания
на моделирование - вкладка измерений в окне параметров симуляции.

Графический модуль
- Добавлена возможность переключения между действительной и комплексной плоскостями отображения графиков в частотном анализе.
- Добавлены кнопки вызова диалогового окна БПФ, функций курсора.


Схемотехнический редактор
- Добавлена возможность вызова диалога редактирования сигналов прямо из окна параметров источков.
- В диалог настроек редактора добавлена возможность настройки в выводимых числах количества знаков после запятой.

Экспорт данных моделирования
- Расширены возможности при экспорте данных в Maple. Теперь кроме матриц схемы экспортируются сигналы временного анализа, начальная ил рабочая точка схемы, уравнения нелинейных токов и емкостей диодов в численном и символьном видах.

Исправления
- Исправлена обработка схемы при наличии “висячих” элементов.
- Исправлено редактирование нетлиста схемы.
- Исправлена обработка элемента K.
- И др.

Изменения в обновлениях версии SimOne 1.2 Beta

Изменения в версии 1.2.0

1. Библиотека компонентов
- Включает в себя более 30.000 моделей реальных электронных компонентов.
- Предоставляет удобный интерфейс подключения SPICE-библиотек (*.lib файлы).
- Предоставляет удобный интерфейс подключения пользовательских графических подсхем.



2. Новые модели компонентов
- n-канальный and p-канальный МОП транзисторы.
- Нелинейные аналоговые функциональные источники тока и напряжения с функциями TABLE, POLY, Expression.

3. Графический модуль
- Добавлена библиотека математических функций и выражений, используемых при построении графиков.



- Добавленные функции курсоров.

4. Схемотехнический редактор
- Добавлена возможность создания, редактирования и удаления текстовых подсхем SPICE-формата.



5. Управление данными моделирования
- Вы можете теперь удобно управлять данными моделирования на жестком диске: каждый файл-схемасоздает свою собственную папку для симуляций и имя симуляций включается в имя файла на диске.

6. Пользовательский интерфейс
- Добавлено меню «График», содержащее следующие разделы:

Список графиков;
Добавить график;
Курсоры;
Отобразить маркеры точек на графике;
Экспорт…

Изменения в обновлениях версии SimOne 1.1 Beta

Изменения в версии 1.1.1

1. Симуляции
- добавлена возможность увеличения скорости моделирования за счет учета латентного состояния элементов. Настройки симуляции: BYPASS, MBYPASS, BYTOL.
- добавленна возможность управления демфированным методом Ньютона. Настройики - soffim, soffimitev;
- изменились настройки симуляции, задаваеммые по-умолчанию DC_RELTOL = 1e-3, LocusTOL1=1e-6,EigenFreqTOL1=1e-6
- в задании расчета по-постоянному току добавлена возможность задания начального приближения;
- добавлен автоматический выбор шага интегрирования во временном анализе;
- поля шага и интервала вывода графиков на экран в параметрах PSS анализа можно не заполнять;

2. Численные методы
- для повышения точности вычислений улучшен алгоритм выбор ведущего элемента в LU-разложении матрицы.

3. Схематик
- результаты симуляции теперь выводятся на схему с тремя знаками после запятой;
- появилась возможность включать и выключать отображение результатов симуляции на схеме;
- в моделях пассивных элементов R, L, C добавлен параметр допуска — TOLERANCE;
- добавлена возможность параметрического задания подсхем;
- реализована возможность использования взаимную индуктивность в подсхемах;

4. Исправленные ошибки
- расчет матричных параметров зависимых источников;
- расчет нелинейных параметров диода;
- метод Junction Gmin при расчете рабочей точки в DC-анализе;
- расчет периодических режимов корректно без выбора графиков для отображения;
- исправлен вывод результатов на экран для схем, в которых присутствуют подсхемы;
- исправлены ошибки загрузки нетлиста в SPICE-формате;

Изменения в версии 1.1.0

1. Анализ периодических режимов схемы
Расчет периодических режимов ведется с помощью пристрелочного метода Ньютона (Shooting Newton), при этом используется высокоэффективный подход — без явного формирования матрицы чувствительности (Matrix Free Approach). В качестве метода решения СЛАУ используется итерационный метод пространств Крылова — Gmres.

2. Схемный редактор
Добавлена возможность отображения на схеме величин переменных состояния в последней точке проведенного временного анализа или анализа периодических режимов.

3. Модуль управления моделированием
— Добавлен интерфейс задания переменных состояния.
— Изменен способ задания начальных условий симуляции. Помимо возможности использовать рабочую точку или загрузить вектор переменных состояния из файла появилась возможность задать значения переменных состояния вручную или использовать нулевые значения.
— Добавлена возможность автоматического выбора максимального количества потоков симуляции. Количество потоков симуляции выбирается в зависимости от типа процессора.

4. Модуль визуализации
При выключенном многовариантном анализе табличные результаты выводятся в виде вертикальных таблиц, а не горизонтальных.

5. Исправления
— Восстановлена возможность переименования соединения полностью.
— При открытии окна задания параметров анализа устойчивости флажки «Отобразить график собственных частот» и «Отобразить таблицу собственных частот» теперь корректно становятся доступными .
— Для подтверждения изменения текстовых полей на схеме больше не требуется нажимать клавишу Enter.

Изменения в обновлениях версии SimOne 1.0 Beta

Изменения в версии 1.0.3

1. Многовариантные виды моделирования схемы
Для каждого вида анализа схемы добавлена возможность проводить:
— Температурный анализ схемы (.TEMP) — проведение текущего расчета при изменении рабочей температуры.
— Параметрический анализ схемы (.PARAM) — проведение текущего расчета при изменении параметров моделей схемных компонентов.
2. Анализ переходных процессов
— Улучшен алгоритм выбора начального шага расчета.
3. Анализ устойчивости
— Добавлена возможность загрузки рабочей точки схемы из файла.
4. Схемные элементы
— Исправлены неточности в расчетах параметров моделей диода, полевых транзисторов NJFET, PJFET, арсенид-галлиевого транзистора GaAsFET, биполярных транзисторов NPN,PNP, NPN4,PNP4.
5. Схемный редактор
— Добавлена возможность перемещать по схеме имена моделей и значения параметров элементов.
— Добавлена возможность редактирования имен и параметров элементов на схеме, не открывая окно параметров.
— Результаты расчета рабочей точки отображаются на схеме.
6. Графический модуль
— Новое ядро графического модуля FastPlot позволяет эффективно отображать большие объемы данных симуляции.
7. Программные технологии
— Новый модуль работы с HDD позволяет проводить симуляции, объем данных которых ограничивается только объемом жесткого диска.
— Реализована эффективная поддержка многоядерной архитектуры процессора, что позволяет одновременно запускать несколько симуляций без потери производительности, а также существенно сократить время выполнения многовариантных видов расчета. Пользователю предоставляется возможность управления максимальным количеством параллельных потоков симуляции.
8. Экспорт данных
— Исправлены ошибки при экспорте данных симуляций. 

Изменения в версии 1.0.2

1. Управление симуляциями
1.1.  Для эффективного использования данных о характерных режимах поведения схемы создан «Помощник симуляции»  («Симуляция–> Настройки–>Общие настройки»). Его применение целесообразно при многократных запусках различных видов анализа без изменения структуры схемы. Для таких  случаев использование «Помощника симуляции» существенно повышает скорость расчетов  и для больших схем ускорение может достигать десятков и сотен раз. 
1.2.  На вкладку настроек симуляции добавлена кнопка для установки всех параметров в состояние «по умолчанию».
1.3.  При задании диапазонов моделирования частотного и временного анализа теперь можно использовать символьные суффиксы — m, p, n и т.п.
1.4.  Изменен формат хранения симуляции. Вместо единого файла .sim данные симуляции теперь разбиты на несколько файлов:
— .xml – параметры симуляции
— .var – информация о векторе выходных переменных
— .dat – результаты симуляции
— .cod – служебная информация
2. Анализ устойчивости
2.1.  Добавлены настройки выбора алгоритма определения окончания вычислений собственных частот схемы (EFCheckToITL) и нулей годографа Михайлова (CheckToITL).
3. Схемные элементы
3.1.  Исправлены неточности в расчетах параметров моделей транзисторов PJFET, PNP, PNP4.
3.2.   В моделях ключей V-Switch и I-Switch добавлен гистерезисный режим переключения (параметры VH, VT, IH, IT). Исправлены неточности в расчете непрерывного режима.
3.3.  Добавлена модель длинной линии без искажений — параметр fading в Tline определяет величину затухания сигнала в линии. Линия без потерь — частный случай этой модели — fading =1.   
4. Экспорт данных
4.1. Добавлена возможность экспортировать результаты расчетов  в  Excel, Matlab и Maple.

Изменения в версии 1.0.1

1. Устойчивость
1.1. Введены различные способы отображения годографа Михайлова — в линейном масштабе и нормированном логарифмическом.
1.2. Устранены неточности расчетов в работе со схемами низкого  порядка (нулевого и первого) и при повторных запусках расчета собственных частот.
2. Статический режим
2.1. Улучшена сходимость всех методов расчета рабочей точки.
2.2. Добавлены параметры  в настройки статического анализа для эффективного управления сходимостью методов
2.3. Исправленные неточности в методах Source stepping, Gmin stepping, Junction Gmin stepping.
2.4. Добавлена возможность сохранения рабочей точки в файл в текстовом формате.
3. Временной анализ, частотный анализ
3.1. Добавлена возможность загрузки рабочей точки из текстового файла.
4. Схемные элементы
4.1. Добавлены модели биполярных транзисторов  NPN,PNP,NPN4,PNP4 — используется модель Гуммель-Пуна.
5. Экспорт данных
5.1. Добавлена возможность экспортировать расчетные данные — матрицы и вектора в формате Matlab и Maple. Это позволяет пользователю произвести расчет устойчивости и частотных характеристик схемы в этих математических пакетах самостоятельно.
6. Импорт данных SPICE-формате
6.1. Устранены неточности при импортировании  независимых источников напряжения и тока и  биполярных транзисторов.
7. Документ
7.1.  Теперь симуляции, созданные для .net документа, загружаются при его следующем открытии, при условии что документ был сохранен после открытия.
8. Интерфейс
8.1. Добавлен диалог «О программе».
8.2. Добавлен пункт меню для открытия руководства пользователя.

Пакет схемотехнического моделирования электронных схем SimOne

SimOne предоставляет пользователям основные типы анализа схем, характерные для SPICE-моделирования:
— Анализ по постоянному току ( .DC).
— Частотный анализ (.AC).
— Временной анализ (.TRAN).
— Представлен новый вид анализа — Анализ устойчивости схемы.

В пакете используются стандартные SPICE-модели компонентов схем, такие как:
— резистор,
— конденсатор,
— индуктивность,
— трансформатор,
— линия передач,
— независимые и управляемые источники тока и напряжения,
— управляемые переключатели,
— диод,
— полевые транзисторы NJFET, PJFET — модель Шихмана-Ходжеса,
— арсенид-галлиевые полевые транзисторы GaAsFET,
— LEVEL = 1...5,
— биполярные транзисторы NPN, PNP
— модель Гуммель-Пуна.

Торговые марки