Инновационный подход к разработке электроникиИнновационный подход к разработке электроники

 

История версий TopoR

Что нового в версии 6.2

Основные нововведения

  1. Добавлены новые формы контактных площадок
    • прямоугольники со скруглёнными углами (рис. 1)
    • прямоугольники со срезанными углами (рис. 2)
    • finger pads (рис. 3).

    Рис. 1. Прямоугольник со скруглёнными углами

    Рис. 2. Прямоугольник со срезанными углами

    Рис. 3. Fingerpads
    Для получения КП такой формы нужно в списке форм редактора КП выбрать картинку прямоугольника со срезанным углом, а затем в свойствах детали указать тип угла (скруглённый или срезанный). Для скруглённых углов задаётся радиус скругления, для срезанных – величина среза. С помощью флажков можно указать, какие именно углы будут обработаны. В частности, finger pad, изображённый на рис.3, получается, если выбран скруглённый тип, а радиус скругления равен половине ширины прямоугольника.
  2. Добавлена возможность подсоединения проводников к углам контактных площадок

    В меню «Дизайн» появился новый пункт – «Настройки подсоединения проводников к КП». Он открывает диалоговое окно (рис. 4).

    Рис. 4. Окно настроек подсоединения
    Нажатие на «+» открывает окно выбора объектов, в котором можно выбирать либо стеки КП, либо отдельные контакты.
    По умолчанию (в режиме «Определять автоматически»), подсоединение к углам разрешается только для скруглённых (или срезанных) углов прямоугольников, имеющих достаточный для этого радиус скругления.
  3. Добавлено редактирование состава цепей (netlist)Редактировать список контактов, входящих в данную цепь, можно двумя способами – через непосредственное переназначение цепи контакта в свойствах контакта или через новый пункт «Состав цепей» редактора параметров:

    Рис. 5. Редактирование состава цепей
    В  панели «Состав цепей» можно удалять контакты из цепи, перемещать их в другую цепь, переименовывать цепи, создавать новые цепи и удалять существующие. Это даёт возможность редактирования списка соединений (netlist) непосредственно в TopoR, без перехода во внешнюю САПР.
    Переназначение цепи в окне свойств контакта показано на рис. 6 на примере контакта U137-13.

    Рис. 6. Окно свойств контакта
    Если кликнуть ссылку «Изменить» в поле «Цепь:», то откроется окно «Изменение цепи» (рис. 7). В нем можно задать цепь, к которой будет относиться данный контакт.

    Рис. 7. Окно Изменение цепи

Другие

  • Поддерживается открытие дизайнов *.fsx, созданных в предыдущих версиях TopoR (начиная с 6.0). Сохранять дизайны можно только в формате последней версии.
  • Кроме «абсолютных» координат курсора теперь показываются и относительные координаты – смещение относительно той точки, в которой было последнее нажатие на левую кнопку мыши.
  • Назначена горячая клавиша по умолчанию для опции «Только активный слой» (Shift + S).
  • Добавлены горячие клавиши для отображения проводников тонкими линиями (по умолчанию не назначена) и для вызова диалога «Изменение цепи» (по умолчанию Shift + N).
  • В контекстное меню редактора добавлены команды «выделить всю цепь» и «включить гибкую фиксацию».
  • После двойного клика по сообщению о нарушении DRC в рабочей области выделяется объект, редактирование которого сможет устранить данное нарушение.
  • Многослойная автотрассировка улучшена и ускорена.

Изменения и исправления

  • Единицы измерения для импортируемых дизайнов теперь устанавливаются автоматически – в соответствии с данными импортируемого файла.
  • После выполнения автопроцедур сохраняется состояние окна поиска.

Изменения в  версии  14.03.2014 6.0.15759

• Добавлена возможность начинать прокладку проводника с дугообразного сегмента.
• Реализовано автоматическое удаление коротких сегментов проводников, возникших в результате перемещении змеек или двухконтактных компонентов.
• В интерфейс переназначения горячих клавиш добавлено разрешение конфликтов назначения.

Изменения в  версии  26.12.2013 6.0.15622

• Добавлена новая цветовая схема TopoR 6.0, приспособленная для работы с 16 металлическими слоями. Схема включена по умолчанию для новых дизайнов.
• Улучшено рисование сетки. Каждая пятая линия или точка рисуется ярче.
• В режиме Freestyle добавлены новые курсоры для индикации особенностей перемещения объектов.
• Исполняемый файл fside.exe переименован в TopoR.exe.
• Добавлены индикаторы процессов для некоторых длительных операций.
• Исправлена ошибка, приводившая к аварийному завершению программы при отмене открытия варианта автотрассировки.

Изменения в версии 28.11.2013 6.0.15513

• В окне автотрассировки на вкладке цепи добавлена возможность группового изменения флага трассировки.
• Исправлена некорректная работа фильтра в окне автотрассировки.
• В меню Справка исправлены ссылки на страницы документации «Горячие клавиши» и «Особенности работы».

Что нового в TopoR 6.0 по сравнению с TopoR 5.4

Интерфейс

  1. Обновлён внешний вид. Изменились панели инструментов и главное меню
  2. Обновлена панель управления проектом. Добавлена вкладка История открытых проектов. Проекты сортируются по дате открытия.
  3. Команда Показать в папке в проводнике Windows открывает каталог с выбранным файлом. Команда Скопировать проект копирует все файлы проекта в выбранный каталог.
  4. Добавлена панель управления автотрассировкой, на которой можно выбирать цепи для трассировки, а также менять настройки автотрассировки. Таблица вариантов автотрассировки отображается после запуска автотрассировки.
  5. Добавлена панель управления следующими автопроцедурами  вычисление формы проводников, оптимизации путей проводников, автоматическая подвижка переходов и компонентов.
  6. В диалог Настройки системыдобавлена вкладка Горячие клавиши. Для большинства операций можно назначить горячую клавишу, а также изменить уже назначенные клавиши.

Редактор топологии

  1. Обновлена панель инструментов редактора. Сходные инструменты сгруппированы. Режим Freestyle теперь является одним из инструментов редактора. Добавлен новый инструмент измерения расстояний между объектами.
  2. Дугообразные сегменты проводников поддерживаются в любом режиме работы редактора.
  3. В режиме Freestyle поддерживается многоуровневый откат.
  4. В режиме ручной прокладки проводников реализован автоматический поиск и индикация пути проводника в текущем слое. Найденный путь можно принять (и тогда проводник будет автоматически проложен) либо продолжить ручную прокладку.
  5. Добавлено контекстное меню, из которого доступны все возможные операции с выделенными объектами.Обновлён и расширен фильтр выделения объектов.
  6. Реализовано автоматическое удаление переходов, ставших избыточными в результате работы автопроцедур.
  7. Быстрая проверка (Online DRC) теперь не показывает «лишних» нарушений там, где на самом деле нарушений нет.

Редактор параметров дизайна

  1. Настройки автопроцедур вынесены из редактора и доступны на соответствующих панелях. Настройки редактирования также перенесены – доступны в диалоговом окне Настройки редактирования.
  2. Помечаются изменённые разделы редактора.
  3. История откатов редактора топологии отделена от редактора параметров.

Автотрассировка

  1. Реализован сценарий «трассировки по частям» без жесткой фиксации геометрической формы проводников. Подвижность ранее проложенных проводников сохраняется во время вычисления оптимальной формы проводников.
  2. Реализована автоматическая разводка дифференциальных сигналов.
  3. Улучшена трассировка BGA – с учетом двухполюсников, расположенных под BGA-компонентом.

Дополнительно

  1. Реализовано восстановление данных после сбоя системы, а также восстановление автотрассировки, если сбой произошёл во время работы автотрассировщика.
  2. Обновлен формат TopoR PCB. Подробную информацию об изменениях можно найти в описании формата TopoR PCB 1.1.2
  3. Все дизайны, разработанные в версиях TopoR не ниже 5.2, могут быть перенесены на новую версию. Для этого необходимо в старой версии экспортировать дизайн в формат TopoR PCB, а затем импортировать полученный файл в версии 6.0.


Изменения в обновлениях версии TopoR 5.4

Изменения в версии 21.05.2013 5.4.14568

Исправлены ошибки:
•    Приложение зависало при работе с таблицей в редакторе стеков контактных площадок, если было переключение фокуса на окно другого приложения.
•     Исправлен импорт файлов DSN, созданных в системе Proteus. В некоторых случаях возникали проблемы с чтением контура платы.
•     Исправлены ошибки процедуры DRC. Иногда появлялись пустые сообщения.
•     Исправлен экспорт дифференциальных пар в PCAD

Изменения в версии 12.03.2013 5.4.14421

Нововведения:
•     При клике в окне сообщений на предупреждении/ошибке/совете соответствующие проводники подсвечиваются без учёта видимости слоёв.
Исправлены ошибки:
•     При экспорте файлов в PCAD не сохранялись прямоугольные детали на механических слоях.

Изменения в версии 7.02.2013 5.4.14362

Нововведения:
•     В предупреждения о несоблюдении правил выравнивания задержек сигналов наряду с информацией о величине задержки добавлена информация о соответствующей длине
Исправлены ошибки:
•     При импорте файлов формата Eagle BRD:
     -     в некоторых случаях неправильно учитывался угол поворота контактов
     -     в некоторых случаях неправильно устанавливался размер площадок переходных отверстий
     -     иногда пропадали проводники на внутренних слоях.
•     В процедуре DRC не учитывались правила зазоров, заданные для отдельных цепей

Изменения в версии 22.1.2013 5.4.14288

Закончился период бета-тестирования, выпущена первая стабильная сборка для версии 5.4.
Исправлены ошибки:
-        Проверка ширин проводников в процедуре DRC иногда приводила к аварийному завершению процедуры.
-        Не всегда правильно выравнивались задержки на разветвлённых дифференциальных сигналах
-        Не добавлялись заданные связи в окне поиска шин сигналов
-         В некоторых случаях не работала процедура восстановления дифф. пар
-         Неправильно обрабатывались области металлизации, наложенные друг на друга  и принадлежащие одной цепи
-        Не работали гиперссылки из пунктов меню Справка► Горячие клавиши и Справка►Особенности работы
См. также список изменений, появившихся в бета-версии 5.4.14203

Изменения в версии 21.12.2012 5.4.14203

1. Добавлена возможность отображать в окне редактора топологии имена контактов и имена цепей контактов. Отображение управляется флажками Имена контактов и Цепи контактов, расположенными на вкладке Объекты панели Управление отображением. По умолчанию оба флажка включены.

2. Добавлен новый инструмент: восстановление дифференциальных пар проводников. Основное предназначение – восстановить информацию о дифференциальных парах, ранее созданных в САПР TopoR. Поскольку такая информация теряется в результате экспорта топологии в другую САПР, то при повторном импорте в TopoR она нуждается в восстановлении. После запуска процедуры Восстановить дифф. пары проводников информация о парах будет восстановлена, а соответствующие проводники окажутся застёгнутыми. Чтобы эта процедура могла отработать, в дизайне должны быть определены соответствующие дифференциальные сигналы. Процедура запускается автоматически при импорте, а также при явном вызове из меню Инструменты ► Восстановить дифф. пары проводников
3. Добавлена поддержка нового текстового формата Eagle BRD. Файлы в этом формате создаются системой Eagle 6.0
4. В настройки экспорта ses файла добавлен параметр Разрешение (Resolution) для управления точностью представления координат. Добавлен новый шаблон настроек для поддержки САПР CADint.
5. Обновилась версия формата TopoR PCB. Подробную информацию об изменениях можно найти в описании формата TopoR PCB 1.1.1
6. Дизайны, разработанные в версии 5.3, будут открываться в новой версии с незначительной потерей информации – параметров прокрутки и масштаба, а также цветовых настроек и настроек видимости. Для сохранения всей информации необходимо предварительно (из версии 5.3) сделать экспорт дизайна в формат TopoR PCB, а затем импортировать полученный файл в версию 5.4.

Изменения в обновлениях версии TopoR 5.3

Изменения в версии 16.11.2012 5.3.14009

1. Исправлена ошибка, приводившая к аварийному завершению экспорта в PCAD.
2. Исправлена ошибка импорта из PCAD, приводившая в некоторых случаях к аварийному завершению программы.
3. Исправлена ошибка автоматической трассировки. В некоторых случаях неправильно учитывались фиксированные ПО в области BGA.
4. Исправлена ошибка, приводившая к зависанию автоматической трассировки.
5. Исправлена сортировка объектов в списках и таблицах. После C1, теперь следует C2, а не C10.
6. Исправлена ошибка импорта из PCAD, приводившая к появлению цепи у монтажных отверстий.

Изменения в версии 17.10.2012 5.3.2.13839

1. В окно статистики добавлена информация о количестве SMD и сквозных контактов.
2. Теперь при завершении прокладки проводника в произвольном месте последнее добавленное переходное отверстие не удаляется.
3. Исправлена ошибка импорта из PCAD контура платы, состоящего из прямых и дуг.
4. Исправлена ошибка, приводившая к зависанию автоматической трассировки.
5. Исправлена ошибочная подсветка объектов при выделении нарушения DRC.
6. Исправлена ошибка, приводившая к аварийному завершению программы при создании сигналов.
7. Исправлена ошибка: в некоторых случаях неправильно вычислялись задержки сигналов.
8. Обновлена справка. Добавлены указатель и возможность поиска.

Изменения в версии 11.09.2012 5.3.2.13674

1. В ручном редакторе реализовано удаление излома проводника при перемещении ПО в непосредственной близости от излома.
2. В ручном редакторе реализовано удаление излома контура области металлизации при перемещении маркера в непосредственной близости от излома.
3. На панели поиска:
- для каждого стека контактных площадок в скобках указывается число контактов с этим стеком;
- для каждого типа перехода в скобках указывается число ПО этого типа.
4. Исправлена ошибка: Неправильно записывалась функциональная эквивалентность контактов при экспорте в PCAD по прототипу.
5. Исправлена ошибка: неправильная сортировка в таблицах редактора параметров дизайна при наличии чисел c запятой.
6. Исправлена ошибка: не работал экспорт дугообразных участков проводников в Expedition.

Изменения в версии 28.06.2012 5.3.2.13430

1. В интерфейсе группировки объектов добавлена возможность исключения объекта из группы путём его перетаскивания на элемент панели навигации Несгруппированные.
2. На механических слоях примитивы зафиксированных компонентов рисуются затемнённым цветом слоя. В старых проектах нужно выбрать ещё раз цвет слоя или цветовую схему, иначе затемнения не будет.
3. При выборе нового цвета по команде Больше цветов в качестве начального цвета устанавливается текущий цвет.
4. В редакторе параметров дизайна на панели Свойства цепейдобавлена возможность множественного выделения цепей и групп цепей для задания им свойств.
5. Изменился экспорт Drill-файлов. Теперь отверстия с разным диаметром записываются в один файл. Разделение по файлам осуществляется только по диапазону слоёв и по признаку металлизации.
6. Исправлена ошибка в процедуре преобразования проводников в полигоны, приводящая в некоторых случаях к аварийному завершению программы.

Изменения в версии 21.05.2012 5.3.2.13213

1. Добавлена горячая клавиша Z для заливки / разливки областей металлизации.
2. Добавлена подсветка связей выделенных сигналов.
3. В строке состояния выводится информация о выделенных сигналах.
4. В строке состояния выводится информация о принадлежности цепей группам.
5. Исправлена ошибка потери цепи монтажных отверстий при импорте из PCAD.
6. Форма площадок ПО при экспорте в PCAD заменена на ‘Ellipse’ (раньше было 'Oval').
7. Исправлены ошибки записи атрибутов дифф. пары, экспортируемой в PCAD.
8. Решена проблема с экспортом маленьких дуг в PCAD

Изменения в версии 09.04.2012 5.3.2.12953

1. В окно поиска добавлены дифференциальные сигналы, группы цепей, группы сигналов и группы компонентов.
2. При выделении объектов из окна поиска учитываются фильтры выделения.
3. В таблице стеков КП в окне редактора параметров дизайна добавлена возможность сортировки.
4. В документации обновлён раздел «Группировка объектов», добавлен раздел «Сигналы»
5. Исправлены ошибки:
— импорта параметров дизайна;
— поиска сигналов.

Что нового в TopoR 5.3 по сравнению с TopoR 5.2

Основные изменения

1. Для представления линий передачи сигналов введён новый тип объектов «сигналы».

Введение сигналов позволяет корректнее (по сравнению с версией 5.2) задавать исходные данные для решения задачи синхронизации задержек в линиях передачи. Изменён способ задания дифференциальных сигналов. Сигнал реализуется последовательностью проводников и (пассивных) двухполюсников.

новый тип объектов сигналы

2. В редакторе параметров дизайна (F4) полностью изменён интерфейс группировки объектов. Добавлена возможность создавать иерархические структуры групп.



3. В редакторе параметров дизайна добавлена возможность копирования параметров из другого дизайна. Параметры копируются из файлов fsx и файлов в формате TopoR PCB (.fst).

копирование параметров из другого дизайна

4. В редакторе топологии (F7) введена возможность копирования и вставки объектов (запреты, области металлизации, контур платы, детали на механических слоях, надписи, переходные отверстия).

5. Существенно снижено количество нарушений DRC за счёт улучшения расчёта оптимальной формы проводников.

6. Добавлена возможность выбора цепей или слоёв для преобразования проводников в полигоны.

7. Добавлена возможность учитывать механические слои при размещении.

учитывать механические слои при размещении

8. Улучшена работа с проектом.
- Добавлена возможность создания проекта при импорте.
- Отслеживание состояния файлов проекта.

9. Добавлена возможность открытия файлов дизайнов из Проводника Windows.

10. Изменилась версия формата TopoR PCB. Подробную информацию об изменениях можно найти в описании формата TopoR PCB 1.1.0

11. Доступен перенос дизайнов, разработанных в версии 5.2 на новую версию. Для этого необходимо предварительно (в версии 5.2) сделать экспорт дизайна в формат TopoR PCB, и импортировать полученный файл в версии 5.3.

Изменения в обновлениях версии TopoR 5.2

Изменения в версии 08.12.2011 5.2.1.12074

1. При создании правил волнового сопротивления для дифференциальных пар столбцы с шириной и зазором автоматически заполняются значениями по умолчанию.
2. В настройках экспорта ses файла в Altium Designer включена аппроксимация дуг.
3. Исправлена ошибка импорта запретов размещения из файлов dsn.
4. Исправлена ошибка импорта функциональной эквивалентности гейтов из файлов dsn.
5. Исправлена ошибка, приводившая к аварийному завершению программы при автоматической подвижке ПО.

Изменения в версии 19.10.2011 5.2.1.11704

1. Добавлена обработка синтаксических ошибок при импорте файлов в формате TopoR PCB.
2. Уменьшены минимальные размеры окна редактора параметров дизайна для работы на небольших экранах.
3. Исправлены ошибки:
— импорта файлов PCAD (не читались цепи монтажных отверстий).
— печати отверстий для фотошаблонов.
— выбора набора слоёв при задании правил ширин и зазоров.
— работы с застёгнутыми парами проводников.
— процедуры обработки вариантов автотрассировки, приводившей к аварийному завершению программы.

Изменения в версии 26.09.2011 5.2.1.11573

1. Устранена проблема, приводившая к аварийному завершению программы при прокладке дифференциальных пар в Lite версии.
2. Разработано описание формата TopoR PCB. Документ в формате pdf доступен для скачивания в разделе «Документация».
3. Прекращена поддержка экспорта в PADS.
4. Исправлены ошибки:
— экспорта / импорта формата TopoR PCB.
— преобразования проводников в полигоны.
— процедуры распутывания «клинчей».

Что нового в TopoR 5.2 по сравнению с TopoR 5.1

Автоматическая трассировка

1. Добавлена возможность использования несквозных переходных отверстий.
2. Добавлены процедуры, распутывающие так называемые «клинчи» проводников.



3. Добавлены процедуры, сокращающие число переходных отверстий на многослойных платах.
4. Добавлена возможность назначения цепям (группам цепей) определённых типов переходных отверстий.
5. Добавлена возможность создания областей запрета переходных отверстий.

Новые средства

1. Добавлена возможность получения полигональной разводки. На оттрассированной плате происходит преобразование всех проводников в полигоны и расширение их до максимально возможных размеров. Полигональная разводка полезна при проектировании силовых устройств.



2. Разработан открытый текстовый формат TopoR PCB. Он будет использоваться для переноса проектов на новые версии TopoR, а также для написания конвертеров к сторонним программам.
3. Расчёт площади металлизации.

Интерфейс

1. Добавлена возможность поиска переходных отверстий по типам.
2. На панель управления отображением добавлены следующие флаги:
— отображение контактных площадок для групп слоёв (вкладка «Слои»)
— отображение монтажных отверстий (вкладка «Объекты»)
— отображение габаритов компонентов (вкладка «Объекты»)
3. На панелях задания правил (ширины, зазоров) в редакторе параметров дизайна (F4) удалён столбец с приоритетом правил. Приоритет теперь задаётся порядковым номером правила в таблице (чем больше номер, тем выше приоритет). Добавлены кнопки для управления приоритетом.
4. На панели «Переходные отверстия» редактора параметров дизайна (F4) удалён столбец «Максимальная ширина проводника». Вместо этого параметра теперь используется назначение цепям (группам цепей) типов переходных отверстий, вынесенное на отдельную панель.
5. Добавлена возможность выделения деталей корпусов компонентов.
6. Форма курсора в ручном редакторе изменяется при прокладке проводников, добавлении областей металлизации, запретов, надписей, переходных отверстий.
7. В меню «Правка» добавлен пункт, позволяющий инвертировать выделен-ное, т.е. невыделенные объекты становятся выделенными и наоборот.
8. На панель инструментов добавлена кнопка создания контура платы.

Прочее

1. Добавлена возможность удаления неиспользуемых стеков контактных площадок.
2. Добавлена новая цветовая схема «Фотошаблон».

Исправлены ошибки

1. Исправлена ошибка печати. Раньше при высоком качестве (600 dpi и выше) печать работала неправильно.
2. Устранено дублирование правил по умолчанию после импорта.
3. Экспорт файлов Drill. Не сохранялись назначенные символы для отверстий.

Изменения в обновлениях версии TopoR 5.1

Изменения в версии 31.05.2011 5.1.128.11102

1. Исправлена ошибка: Расстёгивание застёгнутых проводников с включённой опцией «разрешить дугообразные проводники» приводило к пересечению проводников.
2. Исправлена ошибка экспорта файлов Drill. Некорректно обрабатывались отрицательные координаты со значениями, меньшими единицы.
3. Исправлена ошибка экспорта файлов Gerber. Слои отображаемые в диалоге иногда не соответствовали слоям дизайна.
4. Исправлен импорт/экспорт вырезов в контуре платы.

Изменения в версии 19.05.2011 5.1.128.11001

Изменение в импорте/экспорте файлов PCAD:
1. Добавлен импорт/экспорт запретов на всех слоях внутри корпусов компонентов.
2. Добавлен импорт/экспорт признака фиксации переходных отверстий.
3. Исправлен импорт несквозных фрипадов.

Исправлены ошибки экспорта файлов Gerber:
1. Не экспортировались созданные в TopoR примитивы на слое Assy.
2. Неправильный экспорт полигонов.
3. Исправлена ошибка DRC. Не учитывались надписи в сигнальных слоях.
4. Исправлена ошибка экспорта файлов Drill. Для некоторых отверстий неправильно подставлялся диаметр.
5. Добавлен учёт «капелек» и несквозных фрипадов при заливке полигонов.
6. Импорт dsn-файлов скорректирован с учётом особенностей экспорта dsn-файлов из OrCAD.

Изменения в версии 04.05.2011 5.1.128.10823

1. Исправлена ошибка экспорта в PCAD 2000.
2. Исправлена ошибка экспорта PCAD ASCII PCB по прототипу.
3. Изменена запись экспорта файлов Drill для удобства просмотра их в CAMtastic.
4. Исправлен импорт термалов у полигона из PCAD (ранее не выдерживалась ширина, требовалась повторная перезаливка).
5. Исправлен импорт КП без деталей из Altium Designer.

Изменения в версии 28.04.2011 5.1.128.10773

1. Исправлена ошибка: При переносе сегмента проводника на другой слой удалялся зафиксированный переход.
2. Исправлена ошибка: При импорте dsn-файла, не соответствующего формату, программа вылетала.
3. Изменение в импорте/экспорте файлов PCAD:
— исправлен экспорт параметров дифференциальных пар (по прототипу и без)
— добавлен экспорт групп цепей
— добавлен экспорт несквозных переходов
— добавлен экспорт контактных площадок без деталей
— при экспорте правил учитывается флаг включения/выключения правила
— исправлена ошибка при импорте дополнительного контура платы
— исправлено ошибка при импорте Layer set
— добавлен экспорт в PCAD2000 (в формате отсутствует информация о термалах переходов, о фиксации проводников, информация о толщине спиц задается только родительскому полигону)

Изменения в версии 6.04.2011 5.1.128.10529

1. Исправлена ошибка DRC. Проявлялась при наличии дугообразных проводников.
2. Изменение в импорте/экспорте файлов PCAD:
— чтение/запись правил по слоям
— чтение правил, действующих между группами цепей
— учёт направления обхода при чтении контуров полигонов и запретов
— исправлено чтение надписей (при зеркалировании неправильно рассчитывался угол поворота)
— исправлено чтение планарных КП (если в PCAD добавлялись внутренние слои, КП при последующем импорте в TopoR становилась сквозной)
— запись дефолтного стиля текста
— чтение и запись (по прототипу) атрибута «note»
3. Исправлены ошибки экспорта файлов Drill и Gerber(экспорт запретов в компоненте).

Изменения в версии 14.03.2011 5.1.128.10233

1. В фильтр окна выбора импортируемого файла добавлено расширение edf (аналог dsn-файлов).
2. Запреты трассировки в компонентах отображаются с диагональной штриховкой.
3. Исправлена ошибка: при использовании крупного шрифта некоторые кнопки диалоговых окон были недоступны.

Изменения в версии 10.02.2011 5.1.128.10107

1. Исправлены ошибки подключения проводников к полигональным КП.
2. Исправлены ошибки экспорта в PCAD:
— не экспортировались термалы переходных отверстий, и параметры областей металлизации
— пропадала цепь у незалитых областей металлизации (дуга, окружность, линия)
— крепёжные отверстия типа «Mounting Hole» экспортировались с типом КП «эллипс»

Изменения в версии 25.01.2011 5.1.128.9976

1. Исправлена ошибка панели свойств ПО.
2. Исправлена ошибка переименования дизайнов.

Изменения в версии 19.01.2011 5.1.128.9941

1. Изменения автотрассировки: введён штраф за двойное подключение к планарным контактам, что в ряде случаев позволяет уменьшить количество переходных отверстий.
2. Изменено отображение связей. При наличии выделенных компонентов отображаются связи только этих компонентов.
3. Исправлены схемы отображения сторон размещения. Теперь отображаются сквозные контакты компонентов, расположенных на противоположной стороне.

Изменения в версии 13.01.2011 5.1.128.9908

1. Добавлена обработка совпадения имен компонентов при импорте dsn-файлов.
2. Добавлено чтение функциональной эквивалентности при при импорте dsn-файлов.
3. Исправлено рисование залитых областей металлизации в компонентах.
4. Исправлена ошибка экспорта файлов Gerber.

Изменения в версии 10.12.2010 5.1.128.9818

1. Добавлена возможность переименования файлов, включённых в проект.
2. Улучшено редактирование областей змеек. Добавлено информирование об изменениях области, связанных с особенностями расчёта змеек.
3. Добавлена цветовая схема для вывода на печать негативных фотошаблонов.
4. Контакты зафиксированных компонентов теперь отображаются затемнёнными.
5. Сохраняются размеры всех таблиц в редакторе параметров дизайна.
6. Исправлены ошибки DRC.
7. Исправлены ошибки экспорта файлов DXF и Gerber.
8. Исправлены ошибки ручной прокладки проводников. В некоторых случаях некорректно работало удаление последнего сегмента.
9. Исправлены ошибки выбора слоя для правил зазоров и ширин.

Что нового в TopoR 5.1 по сравнению с TopoR 5.0

Отображение линий связи для неразведённых цепей в ручном редакторе

При перемещении объектов происходит динамическое перестроение линий связи. Во время ручной прокладки проводника отображается специальный целеуказатель.


Рис. 1. Отображение линий связи для неразведённых цепей в ручном редакторе

Автоматическое выравнивание задержек в цепях

Из меню ручного редактора доступна команда «Создать змейки». По команде автоматически создаются змейки на проводниках, нуждающихся в выравнивании.


Рис. 2. Автоматическое выравнивание задержек в цепях

Возможность создания ярлыков

Теперь для каждого атрибута компонента доступно создание любого количества ярлыков. Введены правила редактирования ярлыков, определяющие поведение ярлыков при вращении компонента, а также ориентацию ярлыков.


Рис. 3. Возможность создания ярлыков

Улучшенная панель управления отображением

Все настройки отображения вынесены на отдельную панель. Введены два типа схем: цветовые схемы и схемы отображения (видимости), позволяющие выбирать предварительно сохраненные варианты настроек.


Рис. 4. Улучшенная панель управления отображением

Улучшенные панели свойств выделенных объектов

Панель свойств занимает значительно меньше рабочего пространства, чем прежде. Добавлена возможность быстрого перехода к редактированию контактных площадок и типов межслойных переходов.


Рис. 5. Улучшенные панели свойств выделенных объектов

Создание BOM (Bill Of Materials)–файлов

На их основе можно (например, в САПР «Компас») выпустить комплект текстовой конструкторской документации.

Вывод результатов проектирования на печать


Рис. 6. Вывод результатов проектирования на печать

Ускорена online-проверка правильности разводки

Исправлены ошибки

1. Горячие клавиши обрабатываются независимо от того, в каком окне находится фокус.
2. В окне редактора параметров дизайна теперь работает прокрутка колесом.
3. При добавлении нового слоя для него устанавливается правильный цвет.

Что нового в TopoR 5.0 по сравнению с TopoR 4.3

Управление правилами трассировки

Инструменты для проектирования High-Speed устройств

Взаимодействие со сторонними САПР

Что нового в TopoR 4.3 по сравнению с TopoR 4.2

Основные изменения

1. Добавлена возможность запрета прямого соединения соседних планарных контактов.
2. Добавлена рекомендация по остановке процесса оптимизации: в случае, когда не удается найти новые варианты в течение долгого времени, программа выдаст сообщение о том, что процесс оптимизации может быть остановлен.

Что нового в TopoR 4.2 по сравнению с TopoR 4.1

Основные изменения

1. Кардинально сократилось число нарушений DRC, не обнаруживаемых быстрой проверкой (online DRC).
2. Улучшения в DRC: новое окно настроек, предоставляющее возможность выбора объектов для проверки.
3. Появилась возможность отключать некоторые предупреждения.
4. Появилась возможность запрещать перенос проводников на внешние слои (для многослойных плат) при работе процедуры «оптимизация путей проводников во время перемещения компонентов» (refine).

Что нового в TopoR 4.1 по сравнению с TopoR 4.0

Основные изменения

1. Реализована полноценная работа с областями металлизации («выкусывание» проводников и контактных площадок других цепей, термобарьеры, удаление неподключенных островков и островков с площадью, меньше заданной, выбор вида штриховки).
2. Существенно снижено количество нарушений DRC за счёт более полного учёта размера переходов при автотрассировке.
3. Два вида однослойной трассировки.

Новые возможности ручного редактирования

1. Создание и редактирование контура печатной платы.
2. Поддержка и редактирование новых форм запретов и областей металлизации: полилинии, дуги, прямоугольники, круги и окружности (раньше были только залитые многоугольники).
3. Выравнивание проводников и графических примитивов на сетку.
4. Выравнивание проводников и графических примитивов на углы, кратные 45 градусам.
5. Вращение компонента по клавише пробел.

Прочее

1. Правила трассировки сохраняются отдельно для каждого файла документа (fsx).
2. TopoR.exe может принимать в качестве параметра командной строки имя внешнего pcb-файла или файла проекта (fsr).
3. При экспорте в PCAD появилась возможность использовать файл-прототип.
4. Улучшено отображение редактируемых объектов.
5. При переходах между режимами состояние панели поиска не изменяется.
6. Улучшен способ сортировки элементов в панели поиска.
7. Запоминается последняя открытая панель настроек.
8. Удаление последнего проводника, инцидентного зафиксированному переходу, не приводит к удалению перехода.

Что нового в TopoR 4.0 по сравнению с TopoR 3.1

Основные изменения

1. Добавлен экспорт PADS ASCII PCB и SES (SPECCTRA, ELECTRA) файлов.
2. Переделаны модели и алгоритмы расчета формы проводников, что позволило существенно уменьшить число артефактов, возникавших из-за погрешностей вычисления (налезание проводников на «чужие» контакты, недопустимое сужение зазора и т.д.).
3. Реализован расчет формы проводников без использования дуг окружностей (только отрезками прямых). Используется в режиме редактирования "FreeStyle" как альтернатива варианту с дугами, и всегда — в режиме ручного редактирования. В совокупности с экспортом .ses-файлов это дает возможность использовать TopoR вместо SPECCTRA и ELECTRA.
4. DRC — теперь и в режиме ручного редактирования; при клике на окружности, индицирующей нарушение DRC, осуществляется подсветка конфликтующих элементов топологии, и в окне свойств появляется сообщение с диагностикой нарушения.
5. Добавлена возможность создания полигона (полигонального запрета или области металлизации), а также вырезов в нем.
6. Добавлена возможность редактирования надписей на печатной плате.
7. Переделана функция выделения объектов. Организовано циклическое выделение объектов, находящихся под курсором, а также добавлены фильтры выделения.

Что нового в TopoR 3.1 по сравнению с TopoR 3.0

Трассировка

1. Добавлена специальная трассировка BGA-компонентов.
2. Снижено кол-во нарушений DRC за счёт лучшей расстановки переходных отверстий, а также лучшего контроля расстояний.
3. Автоматическое удаление избыточных переходов.

Интерфейс

1. Новый дизайн, обновлены пиктограммы кнопок на панелях инструментов.
2. Добавлена поддержка русского языка.
3. Улучшена работа с окном сообщений.

Прочее

1. Чтение форматов DSN и PADS.
2. При экспорте в DXF, выбор символов сверловки, вывод платы с символами сверловки.
3. Вывод таблицы сверловки.
4. Добавлены тренировочные сообщения.

Исправлены ошибки

1. При работе с фиксированными проводниками.
2. Автоматической трассировки.
3. Ручного редактирования топологии.

Что нового в TopoR 3.0 по сравнению с TopoR 2.2

Режим авторазмещения (F5)

1. Значительно улучшено автоматическое размещение компонентов (вызывается по нажатию клавиши F9 или кнопки "Start" на панели инструментов). В предыдущих версиях компоненты часто накладывались друг на друга.
2. Области запрета размещения пока не учитываются.
3. Добавлена панель поиска. Позволяет искать компоненты, цепи и падстеки по имени или подстроке.

Режим автотрассировки (F6)

1. Добавлена поддержка проводников с фиксированной геометрией и зафиксированных переходных отверстий.
2. При трассировке учитывается текст в сигнальных слоях.
3. Режим ручного редактирования (F7).
4. Реализован откат для всех команд редактирования.
5. Добавлена панель поиска. Позволяет искать компоненты, цепи и падстеки по имени или подстроке.
6. Добавлена поддержка проводников с фиксированной геометрией и зафиксированных переходных отверстий.
7. Добавлено ручное переключение функционально-эквивалентных контактов (Pin Swap).
8. Добавлено множественное выделение проводников и сегментов.
9. Предоставлен выбор способа подсветки выделенных объектов — цветом или яркостью.

Режим редактирования "FreeStyle" (F8)

1. Добавлена оптимизация топологических путей проводников (refine) в процессе автоматической подвижки компонентов и межслойных переходов (вызывается по нажатию кнопки "Start" на панели инструментов).
2. Добавлена панель поиска. Позволяет искать компоненты, цепи и падстеки по имени или подстроке.
3. Добавлена поддержка проводников с фиксированной геометрией и зафиксированных переходных отверстий.
4. Учитывается текст в сигнальных слоях и слоях шелкографии.

Добавлены следующие функции

1. Экспорт в формат DXF.
2. Генерация GERBER-файлов.
3. Генерация ECO-файла.
4. Вывод всех координат и величин в единых единицах измерения.
5. Учет зазора между проводниками и краем платы.

Торговые марки